Voting doesn't work under FC 155 r607 - SH404 Issue

8 years 8 months ago - 8 years 8 months ago #16695 by tbunte
I update to com_flexicontent_155_stable_r607 on my System, but as result nothing happens for Function Voting.
The function shows the loading Icon, but after it, the article have still 0 Votes.
The Console on Developer Tools shows no error?

Any idea?

Systeminfos:
Jooma 1.5.23
FC 155 r607
FA 1.0.5

best regards,
Thomas

Please Log in or Create an account to join the conversation.

8 years 8 months ago #16704 by bsky92
with every nabigator,

This is weird, I switched to 1.5.5 too and have no problem with voting, but I only use chrome, I'll try with IE and firefox and let you know

Please Log in or Create an account to join the conversation.

8 years 8 months ago #16708 by tbunte
I had it under FF (3.6 and 5) and IE (8) too (standardbrowser was Chromium-Based Iron).

Sample under
http://www.ostwestfalen-lippe-socialmed ... uture.html

best regards,
Thomas

Please Log in or Create an account to join the conversation.

8 years 8 months ago #16721 by bsky92
I tried it , this is weird, it's working really fine on my site.

Did it happen just after you upgraded ?

Please Log in or Create an account to join the conversation.

8 years 8 months ago #16722 by ggppdk
I have managed to vote at the URL you provided, by using a direct link, (don't worry it does not let me vote twice), you can see that i voted for 5 stars :D

Anyway the problem is that the voting function is confused because your installation is in a subfolder called "feed" and you are using SEF URLs.

For some reason JURI::base() doesnot seem to return the joomla subfolder which is then stored in a javascript variable sfolder. I looked at the page source and it is initialized to '' meaning no subfolder.

Put this in your template just before </body>, and it should fix the problem
<script type="text/javascript" language="javascript">
if (typeof sfolder != 'undefined') {
  sfolder = '/feed/';
}
</script>

Other options:

1. Try configuring your SEF component or
2. Try modifying .htaccess file changing line
RewriteBase /
 to
  RewriteBase /feed/
3. Patch the fcvote.js to set sfolder variable

Test the above to see if things voting works and if something breaks ... please post back feedback, if any of the above suggestions work


-- Flexicontent is Free but involves a big effort on our part.
Like the our support? (for a bug-free FC, despite having a long list of functions) Like the features? Like the ongoing development and future commitment to FLEXIcontent?
-- Add your voice to the FLEXIcontent JED listing with a 5-star review. Thanks!

Please Log in or Create an account to join the conversation.

8 years 8 months ago #16728 by bsky92
Really, thanks soooooooooooo much for all the help you are providing to the community :)

Please Log in or Create an account to join the conversation.

8 years 8 months ago #16734 by micker
ggppdk it's my religion !!! ;)

FLEXIcontent is Free but involves a very big effort on our part.
Like the our support? (for a bug-free FC, despite being huge extension) Like the features? Like the ongoing development and future commitment to FLEXIcontent?
-- Add your voice to the FLEXIcontent JED listing reviews. Thanks![/size]

Please Log in or Create an account to join the conversation.

8 years 8 months ago #16739 by tbunte
Hi ggppdk,

first of all many tnx. For 5 Stars ;-) , but espacially for search for the problem!

Interesting was the fact, that there was no installation in subfolder feed.
What i see in source was the link to the rss-feed under folder feed.

As result also the concept of modifying the .htacess with paramater RewriteBase doesn't works. Because these path doesn't exist, it crashes the hole website.

I test it then (on an testinstallation where exactly the same probs happens) with deactivated SEF component.
Problem still happens.

I will no try to check it with your proposal for the template file.

But i still wonder why these "wrong" folder notation happens?

best regards,
Thomas

Please Log in or Create an account to join the conversation.

8 years 8 months ago #16741 by tbunte
Hi,

next testinfo:
To place the
<script type="text/javascript" language="javascript">
if (typeof sfolder != 'undefined') {
  sfolder = '/feed/';
}
</script>
in template before body.
But these doesn't change the reaction of the Voting system. Only sometimes the icon for "loading" shows a redcross then.

best regards,
Thomas

Please Log in or Create an account to join the conversation.

8 years 8 months ago #16751 by ggppdk
Hello,
I don't see the code inside your webpage did you place it and then removed it?


-- Flexicontent is Free but involves a big effort on our part.
Like the our support? (for a bug-free FC, despite having a long list of functions) Like the features? Like the ongoing development and future commitment to FLEXIcontent?
-- Add your voice to the FLEXIcontent JED listing with a 5-star review. Thanks!

Please Log in or Create an account to join the conversation.

Moderators: vistamediajoomlacornerggppdk
© 2018 Flexicontent. All Rights Reserved.