HTTP 500 error after Joomla Upgrade to J3.10 [How to fix website]

3 months 2 weeks ago - 3 months 2 weeks ago #80604 by kspoddar
Hi - I just noticed that the websites which have Flexicontent installed are displaying an HTTP error after upgrading to Joomla 3.10.0. The websites are not accessible any more.
I am not sure which version of Flexicontent was installed before the upgrade. 
However, the websites without Flexicontent are upgrading to Joomla 3.10.0 without any issues. Are others also facing the same problem? And, if yes, is there a workaround?

Best,
Kirti

Cheers!
Kirti

Please Log in or Create an account to join the conversation.

3 months 2 weeks ago - 3 months 2 weeks ago #80606 by ggppdk
Hello

Unfortunately for all broken websites the only way to fix is a manual edit
Only if Flexicontent v3.3.11 is install prior to Joomla update ,  then next manual fix will not be needed

To fix website


1. Edit File  administrator/components/com_flexicontent/definecontants.php

At line 63, replace 3.9.99  with 3.99.99 

if (!defined('FLEXI_J40GE')) define('FLEXI_J40GE', version_compare( $jversion->getShortVersion(), '3.99.99', 'g' ) );


2.  Go to Extension/Manage Database and click Fix
3.
Then upgrade to FC v3.3.11


-- Flexicontent is Free but involves a big effort on our part.
Like the our support? (for a bug-free FC, despite having a long list of functions) Like the features? Like the ongoing development and future commitment to FLEXIcontent?
-- Add your voice to the FLEXIcontent JED listing with a 5-star review. Thanks!

Please Log in or Create an account to join the conversation.

3 months 2 weeks ago #80634 by jps
Same problem !
Solve with the answer from ggppdk

Thank You !

Please Log in or Create an account to join the conversation.

3 months 1 week ago #80646 by kspoddar
Thanks. It worked. You guys are simply amazing!

Cheers!
Kirti

Please Log in or Create an account to join the conversation.

Moderators: vistamediajoomlacornerggppdk
© 2018 Flexicontent. All Rights Reserved.