Nouislider report "TypeError: a is null" and kill my other js

4 months 2 weeks ago #76936 by Natwork
Hi,

i've got a problem on some pages of a website, but not on others.
nouislider.js returns an error and it stops all scripts after it.

Here is the complete message in console :
nouislider.min.js:3 Uncaught TypeError: Cannot read property 'nodeName' of null
    at Object.R [as create] (nouislider.min.js:3)
    at HTMLDocument.<anonymous> (irlande:172)
    at u (jquery.min.js?ca79d0c39bfbf727eb75bd84a1f90b70:2)
    at Object.fireWith [as resolveWith] (jquery.min.js?ca79d0c39bfbf727eb75bd84a1f90b70:2)
    at Function.ready (jquery.min.js?ca79d0c39bfbf727eb75bd84a1f90b70:2)
    at HTMLDocument._ (jquery.min.js?ca79d0c39bfbf727eb75bd84a1f90b70:2)

How to solve this ?

Here is a page where there is this issue : www.bruant-distribution.fr/whisky/irlande
Here is a page with no problem : www.bruant-distribution.fr/whisky/ecosse

Regards

Please Log in or Create an account to join the conversation.

4 months 2 weeks ago #76937 by ggppdk
Hello

are you using the slider in as filtering display of some field ?

backup your custom text of configuration of the slider
and then
try using the default configuration for the slider

does the error go away ?


-- Flexicontent is Free but involves a big effort on our part.
Like the our support? (for a bug-free FC, despite having a long list of functions) Like the features? Like the ongoing development and future commitment to FLEXIcontent?
-- Add your voice to the FLEXIcontent JED listing with a 5-star review. Thanks!

Please Log in or Create an account to join the conversation.

4 months 2 weeks ago #76943 by Natwork

ggppdk wrote: Hello

are you using the slider in as filtering display of some field ?


I'm not using it in any field; I left the default dropdown list.
In FC params, Search / Filter form "form placement" param is set to "inline", in category param is set to "inline" too, and menu item does not override this param.

I'm not displaying filters or alpha index, I don't understand what happen and why on some pages only.

Here is what i've tried:
  • tried to comment the include of tmpl_common in category_alpha -> Error still there
  • tried to comment peer_categories list (with custom text) -> Error still there
  • tried to comment sub_categories list (with custom text) -> Error still there
  • Commenting both doesn't solve the problem either.

So i tried the 'burn it all' method with
unset($doc->_scripts[JURI::root(true) . '/components/com_flexicontent/librairies/nouislider/nouislider.min.js']);
But script is called so i get another error
noUiSlider.create(slider, {
					start: [0, 17],
					connect: true,
 
					step: 1,
				range: {'min': 0, 'max': 17},
			});

ggppdk wrote: does the error go away ?

Sadly still there.

Any other idea ?

Please Log in or Create an account to join the conversation.

4 months 2 weeks ago #76944 by ggppdk
Hello

By looking at the page source

i see that the filtering display of field with ID 53 is created

please go to fields manager and edit field with ID 53
and in the Filtering tabs (yes 2 tabs) of category-based view and search view
set it to have a different filtering display, e.g. set it to be "Select drop down"


-- Flexicontent is Free but involves a big effort on our part.
Like the our support? (for a bug-free FC, despite having a long list of functions) Like the features? Like the ongoing development and future commitment to FLEXIcontent?
-- Add your voice to the FLEXIcontent JED listing with a 5-star review. Thanks!

Please Log in or Create an account to join the conversation.

4 months 2 weeks ago #76947 by Natwork

ggppdk wrote: Hello

please go to fields manager and edit field with ID 53
and in the Filtering tabs (yes 2 tabs) of category-based view and search view
set it to have a different filtering display, e.g. set it to be "Select drop down"


OK i've done this, cleared Joomla / FC & browser cache and stil have the issue. Tried 'search' display & 'dropdown list'...

Error message continue to be the same - do you see anything else ?

Please Log in or Create an account to join the conversation.

4 months 2 weeks ago #76948 by ggppdk
Hello

yes i see, the error for field 53 is now gone

but i see now that it happens for field no 55 too
you need to same thing for field no 55


-- Flexicontent is Free but involves a big effort on our part.
Like the our support? (for a bug-free FC, despite having a long list of functions) Like the features? Like the ongoing development and future commitment to FLEXIcontent?
-- Add your voice to the FLEXIcontent JED listing with a 5-star review. Thanks!

Please Log in or Create an account to join the conversation.

4 months 2 weeks ago #76949 by Natwork
Thanks, it works good now.

ggppdk wrote: Hello
but i see now that it happens for field no 55 too


How can you see this ? i'll do it for each field without anoying you with it

Best regards

Please Log in or Create an account to join the conversation.

Moderators: vistamediajoomlacornerggppdk
© 2018 Flexicontent. All Rights Reserved.