Accents problem on the alphabetic filter

1 month 1 day ago #79989 by voxyahia
  Hello,

I am in the process of setting up a glossary, and I have a problem with the alphabetical filter.

Indeed some of the words in my glossary contain accents, notably the letter "À".

In the alphabetical filter, the filter of the letter "À" (with accent) is active, but the filter of the letter "A" (without accent) is not active, despite that on the page I have words that contain this letter (A without accent). (See screenshots).

Here is my configuration :
############
In Menus -> Parameters -> Search / Filter form -> Alpha index :

Show alpha index : Show, Use Custom List
Custom Alpha Index List  : [default]=a,à,b,c,d,é,e,,f,g,h,i,j,k,l,m,n,o,p,q,r,s,t,u,v,w,x,y,z

CSS classes for AI : letters
character groups

Skip empty Al characters :   No
################

When i unpublished words with the letter "À" (with accents) , the filter with "A" (without accents) becomes active .

I tested for words with "e" and "é" , but I didn't have this problem.

an idea please? Is there a special setting for letters with accents?

Thanks for your feedback
Attachments:

Please Log in or Create an account to join the conversation.

1 month 1 day ago #79990 by micker
i think you need to use alias letter
 

FLEXIcontent is Free but involves a very big effort on our part.
Like the our support? (for a bug-free FC, despite being huge extension) Like the features? Like the ongoing development and future commitment to FLEXIcontent?
-- Add your voice to the FLEXIcontent JED listing reviews. Thanks![/size]
Attachments:

Please Log in or Create an account to join the conversation.

1 month 1 day ago #79991 by voxyahia
Hello Micker, thank you for your quick response and your responsiveness.
I tried this setting:
Show alpha index
 Use Global Hide Show, Use Language Default Show, Use Custom List Show, Use Custom List
 
Custom Alpha Index List : [default]=a,à,b,c,d,é,e,,f,g,h,i,j,k,l,m,n,o,p,q,r,s,t,u,v,w,x,y,z
CSS classes for AI character groups
letters
Custom AI Character Aliases : A~aAà!!E~eéBut that didn't solve my problem, is it the right configuration?
 

Please Log in or Create an account to join the conversation.

1 month 6 hours ago #79994 by ggppdk
Hello

about the characters not working it could be that the character you used in configuration is not of same encoding as the one in DB
what is the character encoding of the Database ?
 


-- Flexicontent is Free but involves a big effort on our part.
Like the our support? (for a bug-free FC, despite having a long list of functions) Like the features? Like the ongoing development and future commitment to FLEXIcontent?
-- Add your voice to the FLEXIcontent JED listing with a 5-star review. Thanks!

Please Log in or Create an account to join the conversation.

1 month 6 hours ago #79996 by voxyahia
Hello ggppdk,

thanks for your feedback, the encoding in the database is utf8mb4_unicode_ci.
I noticed that the filters are not active at the same time, the filter of the letter with accent (example A) is active if the items with the same letter without accents are not published and vice versa
Attachments:

Please Log in or Create an account to join the conversation.

3 weeks 4 days ago #79997 by ggppdk
Hello

you can send me a PM with super admin access (please create a new account)
and give me the frontend url (category based view) you are using for testing


-- Flexicontent is Free but involves a big effort on our part.
Like the our support? (for a bug-free FC, despite having a long list of functions) Like the features? Like the ongoing development and future commitment to FLEXIcontent?
-- Add your voice to the FLEXIcontent JED listing with a 5-star review. Thanks!

Please Log in or Create an account to join the conversation.

3 weeks 4 days ago #80001 by voxyahia
Hello ggppdk
I just sent you the information in PM.
Thanks

Please Log in or Create an account to join the conversation.

2 weeks 4 days ago #80025 by voxyahia
Hello,

Did you identify the origin of this bug, suggest a solution? thank you for your reply
 

Please Log in or Create an account to join the conversation.

2 weeks 3 days ago #80027 by ggppdk
Hello

so i am on vacations since friday,
but i believe i ll have time for this tomorrow


-- Flexicontent is Free but involves a big effort on our part.
Like the our support? (for a bug-free FC, despite having a long list of functions) Like the features? Like the ongoing development and future commitment to FLEXIcontent?
-- Add your voice to the FLEXIcontent JED listing with a 5-star review. Thanks!

Please Log in or Create an account to join the conversation.

1 week 4 days ago #80047 by voxyahia
Hello ggppdk , could you watch for this bug? thank you for your feedback

Please Log in or Create an account to join the conversation.

Moderators: vistamediajoomlacornerggppdk
© 2018 Flexicontent. All Rights Reserved.