[Menu item only for multi-cats view] Flexi filters module - global and not adjusting to current category

6 years 6 months ago - 6 years 6 months ago #54636 by agata
Hello,
I was trying to add filters that would allow visitors to find matching tours on the site I'm developing but even though I configured it to only search in one specific category (the top-level Tours category) and created a hidden menu item loading that category's items, the filters still load values as per current category (but work as intended in item view - that is show all possible values of the filters). I need the module to have the same behaviour regardless of the page it's published on. Perhaps I'm using the wrong module? I didn't see any settings for filters in the flexi search module

Example (the module is published on the top right, "Quick trip search"):
- sandbox-select.wilddog.co.uk/tours - item view landing page for tours, works correctly
- sandbox-select.wilddog.co.uk/tours/subjects - category view for a subcategory of Tours configured to only show subcategories, not their items; doesn't show any values in the filters
- sandbox-select.wilddog.co.uk/tours/subjects/history-politics - sub-sub-category, filters adjusted to the contents
- sandbox-select.wilddog.co.uk/tours/histo...oach-3-days-2-nights - a tour item page, filters again work correctly

The page that the filters should lead to and filter is sandbox-select.wilddog.co.uk/tours/search which is a listing of all items in the subcategories of Tours

Thanks in advance for your assistance with this.
Best,
Agata

Please Log in or Create an account to join the conversation.

6 years 6 months ago - 6 years 6 months ago #54639 by ggppdk
Hello

- menu item configuration will be used, only if you are targetting MULTI-category view

otherwise the menu item is auto-selected, maybe we forgot to update the description


- add a menu item for single category can be a new parameter


-- Flexicontent is Free but involves a big effort on our part.
Like the our support? (for a bug-free FC, despite having a long list of functions) Like the features? Like the ongoing development and future commitment to FLEXIcontent?
-- Add your voice to the FLEXIcontent JED listing with a 5-star review. Thanks!

Please Log in or Create an account to join the conversation.

6 years 6 months ago - 6 years 6 months ago #54640 by agata

Please Log in or Create an account to join the conversation.

6 years 6 months ago #54641 by ggppdk


-- Flexicontent is Free but involves a big effort on our part.
Like the our support? (for a bug-free FC, despite having a long list of functions) Like the features? Like the ongoing development and future commitment to FLEXIcontent?
-- Add your voice to the FLEXIcontent JED listing with a 5-star review. Thanks!

Please Log in or Create an account to join the conversation.

6 years 6 months ago - 6 years 6 months ago #54642 by agata
Sorry, I tried attaching it (selected the file and hit insert button) but it wouldn't attach, in the post above there is a link to the screenshot.
A

Please Log in or Create an account to join the conversation.

6 years 6 months ago #54670 by agata
Did you manage to recreate this behaviour? I have the menu item with the ID specified in the configuration of the module set to multiple categories and the filters to show all values so I don't know what else to do, the filters still try to filter the current category instead of redirecting to the mcats view.
Best,
Agata

Please Log in or Create an account to join the conversation.

6 years 6 months ago - 6 years 6 months ago #54672 by agata
Oh I can see this approach requires to show the category selector (would be handy to be able to select categories but hide the selector) and also the filters can't be dynamic. Could you confirm this is the only way to do this? Ideally I would still be getting the active filters but not per current category but the configured mcats view.

Also, question - how do I get the category image to appear in the mcats view? The options to display the image are there in the menu item and technically what I'm loading is one category anyway so that shouldn't be a problem but I'm not getting the image.
EDIT: scratch that, I can see the menu item can still be single category and it works just fine. I will work on hiding the category selector somehow and just get on with it.
Best,
Agata

Please Log in or Create an account to join the conversation.

Moderators: vistamediajoomlacornerggppdk
© 2018 Flexicontent. All Rights Reserved.