Filters not working any more

2 months 6 days ago #77515 by bytekultur
Hi, we have a whole set of websites with flexicontent using a date field which should be filtered. On most of them, the filters do not work any more since a recent update. The faceted filter shows all options with items - for example like this: 2019-11-24 (2), which indicates two items with that date, but when filtering, the no items message is displayed. I tried with the default template from flexicontent's latest version, but it's still the same.

Could you help?

Example URL that should output one item:
www.rkk-oberdorf.ch/termine?filter_17=2019-11-22

Please Log in or Create an account to join the conversation.

2 months 5 days ago #77521 by micker
Replied by micker on topic Filters not working any more
hello check format of date in field and compare with your url
i think the problem is here

FLEXIcontent is Free but involves a very big effort on our part.
Like the our support? (for a bug-free FC, despite being huge extension) Like the features? Like the ongoing development and future commitment to FLEXIcontent?
-- Add your voice to the FLEXIcontent JED listing reviews. Thanks![/size]

Please Log in or Create an account to join the conversation.

2 months 5 days ago - 2 months 5 days ago #77523 by bytekultur
I have activated the filter to test it, i.e. this URL was created by the filter form, not manually. Is it possible that the filter form creates a URL that isn't compatible with it?

Please Log in or Create an account to join the conversation.

2 months 4 days ago #77526 by bytekultur
For your information: I have many sites with exactly the same settings, only on one it works and on all the others not. All with the same settings though...
www.ref-liestal-seltisberg.ch/termine?filter_17=2019-11-20 here it works (you can click the calendar on the right)

Please Log in or Create an account to join the conversation.

2 months 4 days ago #77527 by ggppdk
Replied by ggppdk on topic Filters not working any more
Hello

this seems to be due to filter configuration

is your filter configured to a "specific value" (checkbox , radio) or is it configured as a range filter


-- Flexicontent is Free but involves a big effort on our part.
Like the our support? (for a bug-free FC, despite having a long list of functions) Like the features? Like the ongoing development and future commitment to FLEXIcontent?
-- Add your voice to the FLEXIcontent JED listing with a 5-star review. Thanks!

Please Log in or Create an account to join the conversation.

2 months 4 days ago #77529 by bytekultur
You mean the filter settings of the field? I tried different ones with no effect. What would make sense is a dropdown or radio, i.e. single value. It's no range filter. Also, if I activate the filter and select one date, it behaves exacktly the same. Also, the filter settings are exactly the same on the page which works and on the ones that don't.
I think I ended up with a radio, as this is the configuration on the page that works.

Please Log in or Create an account to join the conversation.

2 months 4 days ago - 2 months 4 days ago #77530 by ggppdk
Replied by ggppdk on topic Filters not working any more
Hello

Initially did you create this URL via typing it ?

or was it create by a flexicontent filtering form that was submitted ?
mydomain/termine?filter_17=2019-11-22

Also after changing field configuration, did you refresh the filtering form and then try to submit it by selecting an option the filter ?


-- Flexicontent is Free but involves a big effort on our part.
Like the our support? (for a bug-free FC, despite having a long list of functions) Like the features? Like the ongoing development and future commitment to FLEXIcontent?
-- Add your voice to the FLEXIcontent JED listing with a 5-star review. Thanks!

Please Log in or Create an account to join the conversation.

2 months 3 days ago #77535 by micker
Replied by micker on topic Filters not working any more
filter config as georgios said have an impact on filter link

FLEXIcontent is Free but involves a very big effort on our part.
Like the our support? (for a bug-free FC, despite being huge extension) Like the features? Like the ongoing development and future commitment to FLEXIcontent?
-- Add your voice to the FLEXIcontent JED listing reviews. Thanks![/size]

Please Log in or Create an account to join the conversation.

2 months 2 days ago #77550 by bytekultur
Originally, I activated the filter, configured it, and then used exactly that filter format for this custom calendar module, yes. When it didn't work any more, I activated the filter again for category view (showing only when my SuperUser is logged in), tested different configurations and it doesn't work. I mean, the filter shows, I can select a date, it creates the URL I sent you, but there are no items shown. If I have faceted filters with number of items shown - i.e. like this: 2019-01-05 (3) - I can see the system finds 3 items for a specific date, but when selecting that date, it says "there are no items in this category".

The funny thing is: on one site with seemingly exactly the same settings, it works. I also tried to use a different template to make sure it's not our custom template, but it has no effect on it.

Please Log in or Create an account to join the conversation.

2 months 2 days ago #77551 by ggppdk
Replied by ggppdk on topic Filters not working any more
Hello

filter_17=2019-11-20

is same as
filter_17[0]=2019-11-20

which should work if you configure filter with display radio or checkboxes

you said that with display as "checkboxes" it does not work ?


-- Flexicontent is Free but involves a big effort on our part.
Like the our support? (for a bug-free FC, despite having a long list of functions) Like the features? Like the ongoing development and future commitment to FLEXIcontent?
-- Add your voice to the FLEXIcontent JED listing with a 5-star review. Thanks!

Please Log in or Create an account to join the conversation.

Moderators: vistamediajoomlacornerggppdk
© 2018 Flexicontent. All Rights Reserved.