Installation impossible

8 years 1 month ago #34126 by Django29
Bonjour
Sur un Joomla 2.5.9 tout neuf installé en local sur Easyphp dernière version (Apache 2.4.2 - MySQL 5.5.27 - PHP 5.4.6), j'ai un message d'erreur quand j'essaie d'installer Flexicontent :

Une erreur est survenue lors de l'envoi de ce fichier sur le serveur.

Je fais quoi ?

Please Log in or Create an account to join the conversation.

8 years 1 month ago #34127 by micker
Replied by micker on topic Installation impossible
dezip dans le dossier tmp et fait installation avec cet option pour voir

FLEXIcontent is Free but involves a very big effort on our part.
Like the our support? (for a bug-free FC, despite being huge extension) Like the features? Like the ongoing development and future commitment to FLEXIcontent?
-- Add your voice to the FLEXIcontent JED listing reviews. Thanks![/size]

Please Log in or Create an account to join the conversation.

8 years 1 month ago #34133 by ggppdk
Replied by ggppdk on topic Installation impossible
Please note this is not a FLEXIcontent dependent error, your installation failed before FLEXIcontent installer was started.

Make sure your folder
joomlaroot/tmp
is writable

And then read:
Resolving failed installation, because of server limitations


-- Flexicontent is Free but involves a big effort on our part.
Like the our support? (for a bug-free FC, despite having a long list of functions) Like the features? Like the ongoing development and future commitment to FLEXIcontent?
-- Add your voice to the FLEXIcontent JED listing with a 5-star review. Thanks!

Please Log in or Create an account to join the conversation.

8 years 1 month ago #34186 by Django29
Replied by Django29 on topic Installation impossible
Pardon, sorry,j'essayais d'installer le fichier langue au lieu du composant ...
Maintenant, je croyais avoir réussi à l'installer en local, mais le site est tout cassé : plus accès à l'admin, et le haut d'écran rempli d'une centaine de lignes d'erreurs du genre :
Strict Standards: Only variables should be assigned by reference in C:\Program Files\EasyPHP-12.1\www\monsite\administrator\components\...
suivi de :
com_flexicontent\defineconstants.php on line 113
plugins\system\flexisystem\flexisystem.php on line 730
plugins\system\flexiadvroute\flexiadvroute.php on line 52
plugins\system\flexisystem\flexisystem.php on line 454

Please Log in or Create an account to join the conversation.

8 years 1 month ago #34188 by ggppdk
Replied by ggppdk on topic Installation impossible
We have clean many of the strict warnings about 200 for frontend but still not done.

NOTE that PHP strict warnings is meant for developers only and is some times enable in developments servers

See how to disable here:

flexicontent.org/documentation/f ... rvers.html


-- Flexicontent is Free but involves a big effort on our part.
Like the our support? (for a bug-free FC, despite having a long list of functions) Like the features? Like the ongoing development and future commitment to FLEXIcontent?
-- Add your voice to the FLEXIcontent JED listing with a 5-star review. Thanks!

Please Log in or Create an account to join the conversation.

8 years 1 month ago #34195 by Django29
Replied by Django29 on topic Installation impossible
I did this change in php.ini to
error_reporting = E_ALL | ~E_STRICT
and I restarted EasyPHP.

But the hundreds of error lines are still there.

Please Log in or Create an account to join the conversation.

8 years 1 month ago #34200 by ggppdk
Replied by ggppdk on topic Installation impossible
Ok, try this
error_reporting = E_ALL & ~E_STRICT

NOTE: this will not work if some other component or extension changes this to E_ALL

Also make sure that inside Joomla Global Configuration you have error reporting set to OFF


-- Flexicontent is Free but involves a big effort on our part.
Like the our support? (for a bug-free FC, despite having a long list of functions) Like the features? Like the ongoing development and future commitment to FLEXIcontent?
-- Add your voice to the FLEXIcontent JED listing with a 5-star review. Thanks!

Please Log in or Create an account to join the conversation.

8 years 1 month ago #34219 by Django29
Replied by Django29 on topic Installation impossible
Thanks ggppdk, but after this modifications, and restart EasyPHP, all the error messages are still there ...
Anyway it was just for a few extensions tests on localhost. I will soon start the website online, on a temporary domain name.

But of course, it would be easier to make my tests on EasyPHP.

Please Log in or Create an account to join the conversation.

8 years 1 month ago #34232 by micker
Replied by micker on topic Installation impossible
use wamp serveur or serveur2go (a joomla version existe)

FLEXIcontent is Free but involves a very big effort on our part.
Like the our support? (for a bug-free FC, despite being huge extension) Like the features? Like the ongoing development and future commitment to FLEXIcontent?
-- Add your voice to the FLEXIcontent JED listing reviews. Thanks![/size]

Please Log in or Create an account to join the conversation.

8 years 1 month ago #34238 by Django29
Replied by Django29 on topic Installation impossible
J'utilisais wampserver depuis des années, et puis une mise à jour n'a pas voulu fonctionner, malgré différents ajustements.
L'installation de la dernière version de EasyPHP a fonctionné immédiatement, avec Joomla 2.5.9, et 3, Prestashop, Hikashop, Opencart ... jusqu'à l'installation de Flexicontent.

Please Log in or Create an account to join the conversation.

Moderators: vistamediajoomlacornerggppdk
© 2018 Flexicontent. All Rights Reserved.